CDOT Exporting Fieldbook Files
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This document guides you through saving survey fieldbook information to separate MicroStation
files based on a specific drawing scale for ease of referencing and level control.

Exporting a Fieldbook File

Creating a new file

1. From the MicroStation pull-down menu select File > New. The New dialog will
appear.

2. Navigate to the project directory folder
...ROW_Survey\Drawings\Reference_Files.

At the bottom of the dialog box verify that the seed file is set to 3D-
Seed CDOT.dgn.

New - C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\

Savein: | I3 Reference_Files V 9 ¥ = EI‘ P_:"]

M 1234500 _Model.dgn
”3') ] 123455URV_Model.dgn
\ B 123455URY_Topo##Scale##.dgn

My Recent }ﬂ 123455URV_TopoCodes=#5cale=# . dgn
Documents M| 1234550RY_TopoContour ##Scale #2,dan

}ﬂ 123455URV_TopoElevations##Scalex#.dgn
@" }ﬂ 123455URV_TopoMames##Scale #£.dgn
B 123455URY_Topollotes# #5cale# #.dgn

Desktop }ﬂ 123455URV_TopoSymbols #55cale =%, dan

L

My Documents
{ I"J
My Computer
- —
‘k l File name: 567839surv_topo100scale01 dan adl
(- Save as type: MicroStation DG Files (".dgn) V
Seed: |C “Workspace Workspace-COOT_XM'\Standards-GlobalMicroStationseed 3D-5eed_CDOT dan | [ Browse ]

Note: If 3D-Seed_CDOT.dgn is not the seed file specified, <D> Browse
button. Navigate to C:\Program Files\Workspace-CDOT\Standards-
Global\MicroStation\seed and select 3D-Seed_CDOT.dgn from the
Select a Seed File dialog box.

3. Key in the name of the file to be created in the File Name field:
12345SURV_Topo100scaleO1.dgn

4. <D> OK in the New dialog. The New dialog will close and the file
12345SURV_Topol00scale01.dgn will open.
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Setting Up the Survey Options

1. Load InRoads Survey. Verify that the correct *.xin file is loaded and then open a
fieldbook.

Note: The correct *.xin file should either be located in the
C:\Workspace\Workspace-CDOT_XM\Standards-
Global\InRoads\Preferences directory or in a project specific directory.

2. To speed up processing of data, disable the display of dynamic survey graphics

symbols, names, codes, etc. that may be enabled, using the toggles in the View
Survey Data toolbar.

B e e A CH D

3. Verify the correct fieldbook is active. The active fieldbook is indicated by a red
box around the fieldbook icon in the InRoads workspace pane.

¥ 12345surv_fieldbook

4. To modify the scale as it relates to cells, text, and linestyles select Tools > Survey
Options. The Survey Options dialog will appear.

Survey Options
General | LUinits ] Symbology | Correcﬁions] Observation Standard Deviation1
Chord Height: 0.01 Help
Poirt Seed:
Figure Seed:
Cell Scale:
Ted Seale: Fildbook Audi Tiail Fl Name:
Line Scale: | _J
- File Options
¥ Resolve Code Emors I™ Save Computed Coordinates
[+ Log Code Emors [~ Add/Edit Audit Trail
View Options
W Automatic Refresh ¥ Segreqate Text by Feature Level
Planimetric Settings
[v Use Custom Operations W Attach Default Tags
[~ Use Symbols ¥ Attach Attribute Tags
v Uss Cells
I Include Custom Operations, Symbols and Cells in Single Call
QK | Cpen... I Save.. I Save As.. ‘ Cancel ‘

5. On the General tab verify the Scales for Cell, Text, and Line are set to the desired
output scale. This would be the same scale as indicated in the filename in Step 3
of Creating a New File. A scale of 100 is used in this example.
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6. Verify the check box labeled Segregate Text by Feature Level is checked on.

Note: If checked on, Segregate Text by Feature Level will save the symbols,
point names, codes, notes, errors, and elevations to the same level as the
survey feature.

7. <D> Save, then <D> OK. The Survey Options dialog will close.

Write Survey Data to Graphics

1. Once the Survey Options have been verified or changed, write the survey data to
graphics. From the InRoads menu select Survey > View Survey Data > Write
Survey Data to Graphic. The Write Survey Data to Graphics dialog will open.

Write Survey Data to Gra... g [
reie
ply
R [_teey |
T o
[1 =22 MNames
qE
O E Hlevations
ol
O Motes
O Metworl
[]5elect Al
[ ] Planarize
Curve Stroking Mode: |Hu:urizu:unta| and Vertical [V]

Note: If dynamic graphics were toggled on, those same components would be
toggled on in the Write Survey Data to Graphics dialog.

2. Check the Select All check box.

Write Survey Data to Gra... E] [

wz
W

W e
s MNames

z Elevations

o
Motes

Metwork

Select Al
[ ] Planarize
Curve Stroking Mode: | Hanizontal Only [YI
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o g ~ w

Set Curve Stroking Mode to Horizontal Only.

|

B ARP DO EIBREER

level stratified.

Stratify Survey

1. From the CDOT Menu command bar, select CDOT Tools > Stratify Survey.

<D> Apply. The graphics will be created in the design file.
<D> Close. The Survey fieldbook data has been written to the design file.

Verify all dynamic View Survey Data icons are toggled off.

Fit the view of the contents of the design file within MicroStation.

Review the results to verify the data has been written to the design file and are

€ CDOT Menu M=) <
CDOT Groups | COOT Tools  Options Help
Dirafting AutoTrack
Bridge Breakline ®FP d
Constructic  Cell Divide s
Design Change Text Case
Gieometry County Sheet Composer
T?““CS Edit Text Along
nascape INT Translator
Materials fevels Off . \Clip Boundary A
ROW Sury Measure XY Distance \ Match Line
Traffic ITS Mise Too.ls RE {73 Ltility Revision Cloud
Utiltiss ModIlEIEV % Border (Plan 11%17")
Redines = ¥ Border (Flan 11"%8.5") Portrait
Roughen e % Border (Flan 8.5"11") Landsc... =
Si n?:AD % Border (PP 11"%17")
St?ael g ¥ Border (Profile 11"%17")
Stralify Surve % Border (Title 11"%8.5") Portrait
Text to Node ’ % 5 % Border (Typical Section 11"x17")
Traffic Accident % Border Limits (11"%17")
) 2 Call 811 Stamp (Formery UNCC)
Traffic Stripmap % CDOT Logo
Typical Section Program % North Mogw Ckier
| % North Amow Standard
A Ple i MLl [V]
A
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2. The Stratify Survey Data dialog will appear.

L o

Stratify Survey Data

Parameters

T 12345 Scale: [inp Sheet Mumber: |5;

Existing Files
+ fppend " Crverwrite 4l " Crverwrite Mone

Process
Iv adjust Flanimetrics
¥ Svmbals 123455RY _TopoSymbols1005cale01.dgn

v mames 123455URY _TopoMames1005cale01,dgn
v Codes 123455URY _TopoCodes1005cale01.dgn

v Elevations 123455URY_TopoElevations1005cale0l.dgn

M Errars 123455URY _TopoErrors1005cale01.dgn

v mobes 123455URY _TopoMotes1005cale01,dgn

r

Conktours

File Mame: |1 734550RY_TopoContourl005calez_10.dgn
B

(] 4 | Zancel

3. Verify the JPC, Scale, and Sheet Number entries are correct. Altering any of
these values will automatically alter the output file names.

4. If the Attach check box in the Contours section is grayed out, the contour file
does not exist. You may edit the name specified in the File Name field to enter
the name of an existing contour file.

5. Choose one of the follow option from the Existing Files section:
e Append option will add or merge the new data into an existing file. A new

file will be created if the file does not already exist.

e Overwrite All option will create a new file, deleting any previously existing
file.

e Overwrite None option will disable the processing option for a file if the file
already exists.
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6. Toggle on the fieldbook data that should be stratified in the Process section.

Note: Adjust Planemetrics will resize the planemetrics text (if necessary) and
convert the grouped text strings to view independent cells in order to
allow for viewing this text in any 3D view.

7. <D> OK button to start the process.

8. As the data is being moved to the appropriate reference file a Processing Status
dialog provides an update on the progress. You may <D> Cancel at any time to
stop the processing, if necessary.

Processing Status

Planimetrics  Completed (60 elements processed)
Symbaols Completed (1703 elements processed)
Mames working...

Codes

Elevations

Errors

Motes

Contours

Cancel

9. When completed, a Processing Completed message is displayed. <D> OK to exit
the program.

=,

StratifySurvey

\lj) Processing Completed
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10. The fieldbook data has now been stratified into separate reference files. The
planemetrics will be in the master design file with all of the symbols, names,
codes, etc., attached as reference files. To view these attachments select File >
Reference from the MicroStation pull-down menu or click the References icon

in the Primary Tools toolbar

£ References (6 of 6 unique, 6 displayed) E] (m|
Tools  Settings
= ¢ "y e [ = S
E- B a0 £9¢aP P 84500 Guncare ]
Slet | ¥ | File Name Model Description Logical Presentation | ]| .9 | & fj I
1 123455URV_To... CDOT Defautt  Fieldbook Data 1005cale Symbols Wireframe A A
2 123455URV_To... CDOT Default Fieldbook Data 1005caleMames Wireframe A
3 123455URV_To... CDOT Default Fieldbook Data 1005caleCodes Wireframe T
4 123455URV_To... CDOT Default Fieldbook Data 1005caleBlevations  Wireframe B
5 123455URV_To... CDOT Default Fieldbook Data 1005caleEmors Wireframe R
& 123455URV_To... CDOT Default Fieldbook Data 1005caleMotes Wireframe A
Scale | 1.000000 : | 1.000000 Orientation  Top Botation | 0°0°0"
Offset X |-178956.971 Y |-178956.971 Z |-178956.971 i s Sé¢ BB 9 @
Mo Mesting e New Level Display: | Corfig Variable [w|

Referencing Survey Topo Files to Design Files

By using nested references, attaching the master Survey Topo file will also attach all the
references to the specific stratified files as well.

1. Open the design file to that the Topo file should be attached to.

2. From the MicroStation pull-down menu select File > Reference. The
References dialog will appear.

£ References (0 of 0 unique, 0 displayed) E] (m|
Tools  Settings
.E_E - 2 S :5 (1 2 9] _:—3 :‘_\; el i =il 1| Boundaries ||

Slot | ¥ | File Name Model Description Logical Presentation | [o]| .4 | % | {3 I

ElEx ] EE » ¢ Ee ¢ @
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3. From the References pull down menu select Tools > Attach. The Attach
Reference dialog will appear.

Attach Reference - C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\

My Documents

o

My Computer

My Network
Places

Look in: | | Reference_Files

¥ @%@

3 3D-V8DGN
4] 12345R0W_Model.dgn
] 1234550RY _Model.dgn
# 1123455URV_Topo100Scale01.dgn!
] 123455URY_Topo##Scale##.dan %
............ ——

6] 123455URV_TopoCodes 1005cale01.dgn

] 123455URY_TopoCodes##5cale##.dgn
6] 123455URV_TopoContour ##5cale##.dgn
6] 123455URV_TopoElevations 1005cale0 1.dgn
6] 123455URV_TopoElevations##5cale##.dgn
6] 123455URY_TopoErrors100Scale01.dgn

6] 123455URV_TopoMames 1005cale0 1.dgn
6] 123455URV_TopoMames##5cale ##.dgn
6] 123455URV_TopoMotes 1005cale0 1.dgn

6] 123455URY_TopoMotes##Scale##.dgn
6] 123455URV_TopoSymbols 1005cale0 1.dgn
6] 123455URV_TopoSymbals##Scale #£#.dgn

Attachment Method

Interactive

File name: |123455URV_Topo1005cale01 dan ¥ [ open |
Fles oftype: | CAD Files (" dgn;”dwg;" ) [v»] [ _cancel |
i [[] Save Relative Path

4. Set the directory to
...\Projects\12345\ROW_Survey\Drawings\Reference _Files

5. Select the file 12345SURV_Topo100Scale01.dgn and <D> Open. The
Reference Attachment Settings dialog will appear.
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6. From the Nested Attachments drop down list, select Live Nesting and set the
Depth to 1.

ﬂ Reference Attachment Settings for 123455URV_Topo100... e

File Name: 123455URV_Topo100Scale(1.dgn
Full Path: ..\Reference_Files'\12345SURV_Topo1005cale01.dgn
Model: |CDOT Defautt |
Logical Mame:
Description: | Global Origin aligned with Master File

Orientation:
Wiew Description
Coincident Aligned with Master File
Coincident - World Global Origin aligned with Master File
Standard Views

Sawved Views (none)
Mamed Fences {none)

Toagles: E"? o ] E‘_—FJ

Scale (Master:Ref) | 1.000000 : | 1.000000
Mested Attachments: | Live Nesting [+ Depth: |1 |
Display Ovemides: | Allow [+
New Level Display: | Use MS_REF_NEWLEVELL w|
Global LineStyle Scale: | Master [v]
[ oK | [  Camca |

7. <D> OK. The master Survey Topo file will attach along with the fieldbook

nested attachments that contain the symbols, names, codes, etc. of the survey
data.

8. To see the hierarchy of these reference files in the dialog box, Toggle On the
Show Hierarchy button as shown below.

m References (7 of 7 unique, 7 displayed)
Tools Settings
i 4 . o s T 3 T gy
12 % £DE AP D D go D 2% 3 heoss: Bt o]
srchy | | Skt | ¥ | File Name Model Descrip
8 1234505 Modelon T TZ4eSURY Ta. COOTDeledk  Gbat
=iy 123455URV_Topo1005caled.dan
Scale | 1.000000 > | 1.000000
Offset X | 178956 971 ¥ | -178956.971
£ m | [2] | |Live Nesting || | Allow Overides |w| Depth: |1
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